QVert Degraded Performance

Incident Report for Quick Med Claims

Resolved

This incident has been resolved.
Posted Jun 26, 2026 - 16:50 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 26, 2026 - 16:09 EDT

Investigating

We are aware of an issue causing some users to receive a server error when attempting to log in to QVert.

Our team is actively investigating the issue and working to restore normal service as quickly as possible. We apologize for the inconvenience and will provide another update as soon as more information is available.
Posted Jun 26, 2026 - 16:02 EDT
This incident affected: Billing Systems (QVERT Claims).