QVert Degraded Performance

Incident Report for Quick Med Claims

Resolved

This incident has been resolved.
Posted Jul 23, 2025 - 22:25 EDT

Investigating

The QVert application is currently up and running, but users may experience significant slowness. This is due to ongoing database updates required for Qflow, which are expected to continue for several hours. We are actively monitoring performance and will provide updates as the situation improves.

Thank you for your patience.
Posted Jul 23, 2025 - 21:06 EDT
This incident affected: Billing Systems (QVERT Claims).