Danville Rescuenet and File access

Incident Report for Quick Med Claims

Resolved

This is resolved.
Posted Jul 01, 2025 - 10:16 EDT

Monitoring

You can log back into Danville Rescuenet and the File Shares. We will continue to monitor performance.
Posted Jun 30, 2025 - 12:40 EDT

Investigating

The Danville network is experiencing issues. We are aware and are investigating
Posted Jun 30, 2025 - 09:53 EDT
This incident affected: Billing Systems (Danville RescueNet) and File Shares and Printing.