We now believe that the Microsoft Azure outage which was impacting access to the Customer Care Hub is resolved. Our teams continue to work closely to monitor the situation with Microsoft to minimize any impact to our environment.
We appreciate your patience as we worked through the issue.
Posted Oct 29, 2025 - 18:01 EDT
Identified
Per Optum: We are aware of a widespread outage involving Microsoft Azure. Our teams are currently working closely to monitor the situation with Microsoft to minimize any impact to our environment. We appreciate your patience as we work to resolve this issue as quickly as possible
Posted Oct 29, 2025 - 15:26 EDT
Update
Update from Optum: A major cloud service provider is experiencing a DNS-related outage that is disrupting access to its management portal and multiple services. The issue began around 12 PM Eastern Time and is currently impacting all Optum applications. The provider is working to resolve the problem, and we will share updates as soon as additional information becomes available.
Posted Oct 29, 2025 - 13:30 EDT
Investigating
New Incident: multiple products- Production New incident: Investigating We’re currently experiencing performance issues affecting several Change health care applications . Our technical teams are actively working to resolve the problem. We’ll share updates as soon as more information is available.
Posted Oct 29, 2025 - 13:25 EDT
This incident affected: Billing Systems (QVERT Claims).